Back to overview
Downtime

Server upgrade

Jan 30, 2025 at 2:25am UTC
Affected services
Course Search Results
Course Notifications

Resolved
Jan 30, 2025 at 8:28pm UTC

All set

Created
Jan 30, 2025 at 2:25am UTC

We are doing a planned server upgrade. This will be back up soon!