Back to overview
Downtime

Planned database upgrades

Mar 13, 2025 at 7:17pm UTC
Affected services
Course Search Results
Course Notifications

Resolved
Mar 13, 2025 at 7:27pm UTC

All set

Created
Mar 13, 2025 at 7:17pm UTC

We are upgrading some of our services while add/drop is offline. We will be back up soon!